Bitsrapid

Friday, November 23, 2018

LOAD BALANCING 10 MODEM


                  LOAD BALANCING 10 MODEM

ok gaes kali ini saya akan sharing load balancing pcc 10 modem ya gaes.untuk atasi galau FUP Indihome hehe semoga bermanfaat ya gaes/interface ethernet
set [find default-name=ether1] name=ether1
set [find default-name=ether2] name=ether2
set [find default-name=ether3] name=ether3
set [find default-name=ether4] name=ether4
set [find default-name=ether5] name=ether5
set [find default-name=ether6] name=ether6
set [find default-name=ether7] name=ether7
set [find default-name=ether8] name=ether8
set [find default-name=ether9] name=ether9
set [find default-name=ether10] name=ether10
set [find default-name=ether11] name=ether11

/ip address
add address=192.168.11.1/24 network=192.168.11.0 broadcast=192.168.11.255 interface=ether11
add address=192.168.1.10/24 network=192.168.1.0 broadcast=192.168.1.255 interface=ether1
add address=192.168.2.10/24 network=192.168.2.0 broadcast=192.168.2.255 interface=ether2
add address=192.168.3.10/24 network=192.168.3.0 broadcast=192.168.3.255 interface=ether3
add address=192.168.4.10/24 network=192.168.4.0 broadcast=192.168.4.255 interface=ether4
add address=192.168.5.10/24 network=192.168.5.0 broadcast=192.168.5.255 interface=ether5
add address=192.168.6.10/24 network=192.168.6.0 broadcast=192.168.6.255 interface=ether6
add address=192.168.7.10/24 network=192.168.7.0 broadcast=192.168.7.255 interface=ether7
add address=192.168.8.10/24 network=192.168.8.0 broadcast=192.168.8.255 interface=ether8
add address=192.168.9.10/24 network=192.168.9.0 broadcast=192.168.9.255 interface=ether9
add address=192.168.10.10/24 network=192.168.10.0 broadcast=192.168.10.255 interface=ether10

/ip firewall mangle
add chain=input in-interface=ether1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=ether2 action=mark-connection new-connection-mark=WAN2_conn
add chain=input in-interface=ether3 action=mark-connection new-connection-mark=WAN3_conn
add chain=input in-interface=ether4 action=mark-connection new-connection-mark=WAN4_conn
add chain=input in-interface=ether5 action=mark-connection new-connection-mark=WAN5_conn
add chain=input in-interface=ether6 action=mark-connection new-connection-mark=WAN6_conn
add chain=input in-interface=ether7 action=mark-connection new-connection-mark=WAN7_conn
add chain=input in-interface=ether8 action=mark-connection new-connection-mark=WAN8_conn
add chain=input in-interface=ether9 action=mark-connection new-connection-mark=WAN9_conn
add chain=input in-interface=ether10 action=mark-connection new-connection-mark=WAN10_conn

add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2
add chain=output connection-mark=WAN3_conn action=mark-routing new-routing-mark=to_WAN3
add chain=output connection-mark=WAN4_conn action=mark-routing new-routing-mark=to_WAN4
add chain=output connection-mark=WAN5_conn action=mark-routing new-routing-mark=to_WAN5
add chain=output connection-mark=WAN6_conn action=mark-routing new-routing-mark=to_WAN6
add chain=output connection-mark=WAN7_conn action=mark-routing new-routing-mark=to_WAN7
add chain=output connection-mark=WAN8_conn action=mark-routing new-routing-mark=to_WAN8
add chain=output connection-mark=WAN9_conn action=mark-routing new-routing-mark=to_WAN9
add chain=output connection-mark=WAN10_conn action=mark-routing new-routing-mark=to_WAN10

add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=ether11
add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=ether11
add chain=prerouting dst-address=192.168.3.0/24 action=accept in-interface=ether11
add chain=prerouting dst-address=192.168.4.0/24 action=accept in-interface=ether11
add chain=prerouting dst-address=192.168.5.0/24 action=accept in-interface=ether11
add chain=prerouting dst-address=192.168.6.0/24 action=accept in-interface=ether11
add chain=prerouting dst-address=192.168.7.0/24 action=accept in-interface=ether11
add chain=prerouting dst-address=192.168.8.0/24 action=accept in-interface=ether11
add chain=prerouting dst-address=192.168.9.0/24 action=accept in-interface=ether11
add chain=prerouting dst-address=192.168.10.0/24 action=accept in-interface=ether11

add chain=prerouting dst-address-type=!local in-interface=ether11 per-connection-classifier=both-addresses-and-ports:10/0 action=mark-connection new-connection-mark=ether1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=ether11 per-connection-classifier=both-addresses-and-ports:10/1 action=mark-connection new-connection-mark=ether2_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=ether11 per-connection-classifier=both-addresses-and-ports:10/2 action=mark-connection new-connection-mark=ether3_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=ether11 per-connection-classifier=both-addresses-and-ports:10/3 action=mark-connection new-connection-mark=ether4_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=ether11 per-connection-classifier=both-addresses-and-ports:10/4 action=mark-connection new-connection-mark=ether5_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=ether11 per-connection-classifier=both-addresses-and-ports:10/5 action=mark-connection new-connection-mark=ether6_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=ether11 per-connection-classifier=both-addresses-and-ports:10/6 action=mark-connection new-connection-mark=ether7_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=ether11 per-connection-classifier=both-addresses-and-ports:10/7 action=mark-connection new-connection-mark=ether8_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=ether11 per-connection-classifier=both-addresses-and-ports:10/8 action=mark-connection new-connection-mark=ether9_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=ether11 per-connection-classifier=both-addresses-and-ports:10/9 action=mark-connection new-connection-mark=ether10_conn passthrough=yes
add chain=prerouting connection-mark=ether1_conn in-interface=ether11 action=mark-routing new-routing-mark=to_ether1
add chain=prerouting connection-mark=ether2_conn in-interface=ether11 action=mark-routing new-routing-mark=to_ether2
add chain=prerouting connection-mark=ether3_conn in-interface=ether11 action=mark-routing new-routing-mark=to_ether3
add chain=prerouting connection-mark=ether4_conn in-interface=ether11 action=mark-routing new-routing-mark=to_ether4
add chain=prerouting connection-mark=ether5_conn in-interface=ether11 action=mark-routing new-routing-mark=to_ether5
add chain=prerouting connection-mark=ether6_conn in-interface=ether11 action=mark-routing new-routing-mark=to_ether6
add chain=prerouting connection-mark=ether7_conn in-interface=ether11 action=mark-routing new-routing-mark=to_ether7
add chain=prerouting connection-mark=ether8_conn in-interface=ether11 action=mark-routing new-routing-mark=to_ether8
add chain=prerouting connection-mark=ether9_conn in-interface=ether11 action=mark-routing new-routing-mark=to_ether9
add chain=prerouting connection-mark=ether10_conn in-interface=ether11 action=mark-routing new-routing-mark=to_ether10

/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_ether1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_ether2 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.3.1 routing-mark=to_ether3 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.4.1 routing-mark=to_ether4 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.5.1 routing-mark=to_ether5 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.6.1 routing-mark=to_ether6 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.7.1 routing-mark=to_ether7 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.8.1 routing-mark=to_ether8 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.9.1 routing-mark=to_ether9 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.10.1 routing-mark=to_ether10 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.3.1 distance=3 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.4.1 distance=4 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.5.1 distance=5 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.6.1 distance=6 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.7.1 distance=7 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.8.1 distance=8 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.9.1 distance=9 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.10.1 distance=10 check-gateway=ping

/ip firewall nat
add chain=srcnat out-interface=ether1 action=masquerade
add chain=srcnat out-interface=ether2 action=masquerade
add chain=srcnat out-interface=ether3 action=masquerade
add chain=srcnat out-interface=ether4 action=masquerade
add chain=srcnat out-interface=ether5 action=masquerade
add chain=srcnat out-interface=ether6 action=masquerade
add chain=srcnat out-interface=ether7 action=masquerade
add chain=srcnat out-interface=ether8 action=masquerade
add chain=srcnat out-interface=ether9 action=masquerade
add chain=srcnat out-interface=ether10 action=masquerade

/ip dns
set servers=8.8.8.8,8.8.4.4

No comments:

Post a Comment